TCP-pinojen haavoittuvuus

Uusien Linux-käyttöjärjestelmäversioiden ja tuettujen FreeBSD-versioiden verkkototeutuksesta on löydetty haavoittuvuus, jota hyväksikäyttämällä voidaan toteuttaa palvelunestohyökkäyksiä pienillä pakettimäärillä. Hyökkäys vaatii jatkuvaa TCP-yhteyttä avoimeen porttiin kohdepalvelimella.

Haavoittuvuus liittyy TCP-segmenttien käsittelyyn Linux- ja FreeBSD-ydinten TCP/IP-protokollapinoissa. Hyökkäys vaatii kaksisuuntaisen TCP-yhteyden muodostamisen avoimeen porttiin kohdepalvelimella. Hyökkäyksellä voi aiheuttaa kohdepalvelimeen korkeaa prosessorikuormaa ja siten saada aikaiseksi palvelunestotilan. Hyökkäys tapahtuu muodostamalla ja ylläpitämällä tietynlaisia TCP-yhteyksiä, minkä vuoksi hyökkääminen ei onnistu käyttäen väärennettyjä lähdeosoitteita.

Haavoittuvuuskoordinointi:

CERT-FI toimi haavoittuvuuskoordinoijana yhteistyössä haavoittuvuuden löytäjän ja ohjelmistokehittäjien kanssa. Haavoittuvuuden löysi Juha-Matti Tiili Aalto-yliopiston Tietoliikenne- ja tietoverkkotekniikan laitokselta ja Nokia Bell Labsilta. CERT-FI kiittää haavoittuvuuden löytäjää, ohjelmistokehittäjiä ja CERT/CC:tä yhteistyöstä.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
  • Verkon aktiivilaitteet
  • Sulautetut järjestelmät
  • Muut
Lisätietoa +

Hyökkäystapa

  • Etäkäyttö
  • Ilman käyttäjän toimia
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Palvelunestohyökkäys
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

  • Linux kernel -versio 4.9 ja sitä uudemmat versiot. Haavoittuvuus on korjattu versioissa 4.9.117, 4.17.11 ja 4.14.59. Versioon 4.4.146 on tuotu osa samasta korjauksesta.
  • Kaikki tuetut FreeBSD-versiot

Ratkaisu- ja rajoitusmahdollisuudet:

Päivitä haavoittuva järjestelmä korjattuun versioon. Linux-jakelujen käyttäjien osalta suositeltavin tapa tähän on jakelijan tarjoamat päivityspalvelut.

Haavoittuvuuden vaikutuksia voi lieventää rajoittamalla pääsyä haavoittuvaan palveluun, tai terminoimalla TCP-yhteydet esimerkiksi välitys- tai kuormanjakopalvelimella.

Haavoittuvuuskoordinoinnin yhteystiedot:

CERT-FI haavoittuvuuskoordinoinnin tavoittaa seuraavasti:

Sähköposti: vulncoord@ficora.fi

Mainitkaa tapausnumero [FICORA #1052508] viestin otsikossa.

Muut yhteystiedot:

https://www.viestintavirasto.fi/kyberturvallisuus/viestintavirastontietoturvapalvelut/cert-fi.html

Lisätkää postiosoitteeseen sana haavoittuvuuskoordinointi.CERT-FI suosittelee PGP- tai SMIME-salauksen käyttöä haavoittuvuuskoordinointiasioita käsiteltäessä. Avaimistomme löytyvät yhteystietojen yhteydestä.

CERT-FI:n haavoittuvuuskoordinoinnin periaatteet ovat luettavissa osoitteesta:

https://www.viestintavirasto.fi/attachments/vulncoord/68RKKzUHm/Haavoittuvuuksien_koordinointipolitiikka_1.1.pdf

Lisätietoa:

Päivityshistoria

Asiasanat: Internet , Tietoturva , CERT , Haavoittuvuuskoordinointi , NCSC-FI

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00561 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248