Vakava haavoittuvuus wget-ohjelmistossa

GNU Wget -ohjelmistosta on löydetty vakava haavoittuvuus, joka mahdollistaa paikallisen tiedoston ylikirjoittamisen hyökkääjän määrittelemällä tiedostolla.

Wget on muun muassa HTTP- ja FTP-protokollaa tukeva tiedostojen lataamiseen tarkoitettu komentorivipohjainen työkalu.

Wget-ohjelmistosta on löydetty haavoittuvuus, jonka avulla hyökkääjä voi kirjoittaa tiedoston uhrin paikalliseen hakemistoon. Haavoittuvuus johtuu puutteellisesta osoitteen tarkistuksesta HTTP-uudelleenohjauksen yhteydessä.

Haavoittuvuuden hyödyntäminen edellyttää, että uhri lataa tiedoston hyökkääjän hallitsemalta palvelimelta. Haavoittuvuus koskee myös palvelinsovelluksia, jotka hyödyntävät wget-työkalua välillisesti.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
Lisätietoa +

Hyökkäystapa

  • Etäkäyttö
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Komentojen mielivaltainen suorittaminen
  • Tietojen muokkaaminen
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

GNU wget ennen versiota 1.18.

Ratkaisu- ja rajoitusmahdollisuudet:

Päivitä ohjelmisto versioon 1.18.

Useissa Linux-jakeluissa korjaus on tuotu myös wget-ohjelman vahempiin versioihin.

Lisätietoa:

Päivityshistoria

Asiasanat: Tietoturva , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00561 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248