PHP:n uudet versiot sisältävät tietoturvapäivityksiä

PHP-ajoympäristöstä on julkaistu uudet versiot 7.0.8, 5.6.23 ja 5.5.37. Uudet versiot korjaavat lukuisia haavoittuvuuksia.

Uusien versioiden korjaamat haavoittuvuudet liittyvät erilaisiin virheisiin mustinkäsittelyssä. Haavoittuvuudet voivat johtaa PHP-sovelluksen kaatumiseen tai pahimmillaan mahdollisesti mielivaltaisen ohjelmakoodin suorittamiseen.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
Lisätietoa +

Hyökkäystapa

  • Etäkäyttö
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Komentojen mielivaltainen suorittaminen
  • Palvelunestohyökkäys
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

  • PHP 7.0.7 ja sitä vanhemmat versiot
  • PHP 5.6.22 ja sitä vanhemmat versiot
  • PHP 5.5.36 ja sitä vanhemmat versiot

Ratkaisu- ja rajoitusmahdollisuudet:

Päivitä PHP korjattuun versioon.

Lisätietoa:

Päivityshistoria

Asiasanat: Tietoturva , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00181 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248