Drupal-julkaisujärjestelmän uudet versiot korjaavat haavoittuvuuksia

Drupal-julkaisujärjestelmän uudet versiot 8.1.3 ja 7.44 korjaavat kaksi kohtalaisen kriittiseksi arvioitua haavoittuvuutta. Valmistaja suosittelee ohjelmiston päivittämistä haavoittuvuuksien korjaamiseksi. Päivitykset voi ladata valmistajan sivuilta.

Haavoittuvuudet löytyvät Drupalin User- ja Views -moduuleista. Vakavampi haavoittuvuus user-moduulissa voi johtaa tilanteeseen, jossa rekisteröityneelle käyttäjälle myönnetään sivuston kaikki roolit. Tällöin käyttäjä voi saada pääkäyttäjätason oikeudet.

Drupalin kehittäjät ovat antaneet haavoittuvuudelle tunnisteen SA-CORE-2016-002. Haavoittuvuuksille ei ole vielä saatavilla CVE-numeroita.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
Lisätietoa +

Hyökkäystapa

  • Ilman kirjautumista
  • Etäkäyttö
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Käyttövaltuuksien laajentaminen
  • Luottamuksellisen tiedon hankkiminen
  • Suojauksen ohittaminen
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

  • Drupal core 7.x ennen versiota 7.44
  • Drupal core 8.x ennen versiota 8.1.3

Ratkaisu- ja rajoitusmahdollisuudet:

Päivitä ohjelmistot uusimpiin versioihin valmistajan ohjeiden mukaisesti.

  • Drupal core 7.x versioon 7.44
  • Drupal core 8.x versioon 8.1.3

Lisätietoa:

https://www.drupal.org/SA-CORE-2016-002

https://www.drupal.org/blog/drupal-8-1-3-and-7-44

Päivityshistoria

Asiasanat: Tietoturva , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00561 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248