NTP.org:n NTP-palvelinohjelmistossa on korjattu useita haavoittuvuuksia

NTP.org NTP-palvelinohjelmiston (ntpd) versiossa ntp-4.2.8p on korjattu useita haavoittuvuuksia, jotka mahdollistavat palvelunestohyökkäyksen aiheuttamisen väärennetyillä tai tietyllä tavoilla muotoilluilla paketeilla.

NTP on palvelimien ja verkkolaitteiden sisäisten kellojen synkronointiin tarkoitettu protokolla. Versiossa ntp-4.2.8p korjatut haavoittuvuudet liittyvät puutteelliseen autentikointiin ja syötteentarkistukseen väärennettyjä paketteja käsitellessä. Haavoittuvuuksien onnistunut hyväksikäyttö mahdollistaa etäkäyttäjän aiheuttaman palvelunestohyökkäyksen joko ntpd-sovelluksen kaatamalla tai NTP-palvelimen naapuruuksiin vaikuttamalla.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
  • Verkon aktiivilaitteet
Lisätietoa +

Hyökkäystapa

  • Ilman kirjautumista
  • Etäkäyttö
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Palvelunestohyökkäys
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

  • ntpd ennen versiota ntp-4.2.8p
  • Verkon aktiivilaitteet ja sulautetut järjestelmät, joissa haavoittuva ntpd-versio on käytössä

Ratkaisu- ja rajoitusmahdollisuudet:

  • Päivitä NTP-palvelinohjelmisto versioon ntp-4.2.8p
  • Päivitä ntpd:tä käyttävät muiden valmistajien tuotteet, kun korjaus on saatavilla

Lisätietoa:

Päivityshistoria

Asiasanat: Tietoturva , Kyberturvallisuus , NCSC-FI , Palvelunestohyökkäys , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00181 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248