TYPO3 sisällönhallintajärjestelmässä kriittinen haavoittuvuus

Suositusta TYPO3 verkkosivustojen sisällönhallintajärjestelmästä on löytynyt kriittinen haavoittuvuus, mikä voi mahdollistaa luottamuksellisen tiedon lukemiseen tai mielivaltaisen ohjelmakoodin suorittamisen etänä.

Haavoittuvuus liittyy TYPO3:n Extbase-kyselyihin, joissa ei tehdä riittävää syötteentarkistusta. Mikäli hyökkääjällä on pääsy ainakin yhteen Extbase laajennokseen tai moduuliin, voi hyökkääjä päästä käsiksi luottamuksellisiin tietoihin tai suorittaa haluamaansa ohjelmakoodia muokkaamalla järjestelmään tehtäviä Extbase-kyselyitä.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
Lisätietoa +

Hyökkäystapa

  • Etäkäyttö
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Komentojen mielivaltainen suorittaminen
  • Luottamuksellisen tiedon hankkiminen
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
  • Ongelman rajoittaminen
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

Haavoittuvuus on korjattu TYPO3 versioissa 6.2.24, 7.6.8 ja 8.1.1.

Ratkaisu- ja rajoitusmahdollisuudet:

Asenna päivityspaketti ohjelmiston valmistajan ohjeiden mukaisesti, tai asenna erillinen korjaustiedosto käytössä olevan ohjelmistoversion mukaisesti.

Lisätietoa:

https://typo3.org/news/article/missing-access-check-in-typo3-cms/

Päivityshistoria

Asiasanat: Tietoturva , CERT , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00181 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248