PCRE-ohjelmistokirjastossa ylivuotohaavoittuvuus

Laajasti käytetystä PCRE-ohjelmistokirjastosta on löydetty muistiylivuotohaavoittuvuus, jonka onnistunut hyväksikäyttö mahdollistaa hyökkääjän ohjelmakoodin suorittamisen.

Säännöllisten lausekkeiden käsittelyyn tarkoitettua PCRE-ohjelmistokirjastoa käytetään usein osana muita ohjelmia, kuten PHP tai Apache-palvelin. Ohjelmistokirjastosta on löydetty muistiylivuotohaavoittuvuus, jonka onnistunut hyväksikäyttö mahdollistaa hyökkääjän ohjelmakoodin suorittamisen. PCRE-ohjelmistokirjastosta on olemassa kaksi pääversiota, alkuperäinen PCRE ja uudempi PCRE2. Tämä haavoittuvuus koskee alkuperäistä PCRE-pääversiota.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
Lisätietoa +

Hyökkäystapa

  • Paikallisesti
  • Ilman kirjautumista
  • Etäkäyttö
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Komentojen mielivaltainen suorittaminen
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Ei päivitystä
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

Ohjelmistot, jotka hyödyntävät PCRE-ohjelmistokirjaston versiota 8.38 tai aikaisempia versioita

Ratkaisu- ja rajoitusmahdollisuudet:

Mahdollisuuksien mukaan korvaa haavoittuva versio viimeisimmällä ohjelmistoversiolla PCRE2 10.20.

Lisätietoa:

Päivityshistoria

Asiasanat: Tietoturva , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00181 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248