VMware vRealize Orchestrator ja vCenter Orchestrator päivittyivät

VMware on korjannut kriittisiä haavoittuvuuksia vRealize Orchestrator - ja vCenter Orchestrator -tuotteissa. Haavoittuvuus liittyy sarjallistamisen purkuun (deserialization) ja mahdollistaa hyökkääjän ohjelmakoodin suorittamiseen etänä.

VMwaren virtualisointituotteissa vRealize Orchestrator, vCenter Orchestrator , vRealize Operations ja vCenter Operations on haavoittuvuus, joka liittyy sarjallistamisen purkuun (deserialization) Apache Commons Collections -kirjastoa käytettäessä.

Haavoittuvuuden onnistunut hyväksikäyttö mahdollistaa ohjelmakoodin suorittamisen etänä Commons Collections -kirjastoa käyttävän sovelluksen oikeuksin vRealize Orchestrator - ja vCenter Orchestrator -tuotteiden tapauksessa. Näille ohjelmistoille on julkaistu korjaava päivitys. Muiden tuotteiden kohdalla haavoittuvuus ja korjauspäivitys julkaistaan myöhemmin.

  • Palvelimet ja palvelinsovellukset
  • Työasemat ja loppukäyttäjäsovellukset
  • Verkon aktiivilaitteet
  • Matkaviestinjärjestelmät
  • Sulautetut järjestelmät
  • Muut

Kohde

  • Palvelimet ja palvelinsovellukset
Lisätietoa +

Hyökkäystapa

  • Paikallisesti
  • Ilman kirjautumista
  • Etäkäyttö
  • Ilman käyttäjän toimia
Lisätietoja hyökkäystavasta +

Hyväksikäyttö

  • Komentojen mielivaltainen suorittaminen
  • Käyttövaltuuksien laajentaminen
Lisätietoja hyväksikäytöstä +

Ratkaisu

  • Korjaava ohjelmistopäivitys
  • Ei päivitystä
Lisätietoja ratkaisusta +

Haavoittuvat ohjelmistot:

  • vRealize Orchestrator 6.x
    • versio 7.0 ei ole haavoittuva
  • vCenter Orchestrator 5.x
  • vRealize Operations 6.x Windows-käyttöjärjestelmässä (haavoittuvuus mahdollistaa vain paikallisen käyttövaltuuksien laajentamisen)
  • vCenter Operations 5.x Windows-käyttöjärjestelmässä (haavoittuvuus mahdollistaa vain paikallisen käyttövaltuuksien laajentamisen)
  • vCenter Application Discovery Manager (vADM) 7.x

Ratkaisu- ja rajoitusmahdollisuudet:

Asenna korjaava ohjelmistopäivitys KB2141244 valmistajan ohjelmiston mukaisesti. Koskee tuotteita:
  • vRealize Orchestrator 6.x
  • vCenter Orchestrator 5.x
Päivitys on tulossa muihin tuotteisiin.

Lisätietoa:

Päivityshistoria

Asiasanat: Tietoturva , Kyberturvallisuus , NCSC-FI , Haavoittuvuudet

LinkedIn Print

Yhteystiedot

logo

Viestintävirasto

Kyberturvallisuuskeskus

PL 313, 00561 Helsinki


Mediayhteydenotot puhelimitse 0295 390 248